Help Center

Why the games do not launch?

If the assessment, training or simply any games do not launch, please read these articles first:
 - System requirements
 - Adobe Flash Player (CogniFit is based on flash technology, so you need the latest version of Adobe Flash Player to use it. Click here to download the latest version related to your operating system and browser).

If the issue remains, please read the following article: "Why won't the training program launch even though Adobe Flash player's most recent version is installed?"