Help Center

Installing and updating Adobe Flash Player

To be able to launch your training and play the different tasks, you need to have a compatible version of Adobe Flash Player installed on your computer.

The minimum requirement to use CogniFit is the version 16 of Adobe Flash Player. When you install or update Adobe Flash Player, you automatically get the latest version of the program. Please also check that your system also meet with Adobe's minimum requirements and CogniFit's minimum requirements.

Special Consideration For Mac users

You need to make sure your Mac's Operating System (OS) version is at least the version 10.6 to be able to download the latest version of Adobe Flash Player. If your OS version is 10.5 or lower, you will first need to upgrade your Mac's Operating System to then be able to download the latest version of Adobe Flash Player.

You won't be able to download the latest version of Adobe Flash Player if you don't have at least the version 10.6 on your Mac Operating System. Even if you try to download Adobe Flash Player, you will be downloading automatically the version 10.3 of Adobe Flash Player which is incompatible with our programs.

To check which Operating System version you have, you need to click on the Apple logo on the top left corner of your screen and select "About This Mac".

operating system version

If the version of your OS is lower than 10.6, you will need to update your OS version by simply clicking on the "Software Update", located in the Apple menu, which will automatically check for the latest Apple software using the Internet. If your computer does not let you update your OS to the latest version, it means that your computer does not meet Apple minimum requirements related to the updated. Please contact Apple support for more information regarding Mac OS update.

To download the latest version of flash player, click here. Make sure that you download the latest version of Adobe Flash Player.

If you cannot download this version because your computer does not meet the necessary requirements to update to the Operating System version 10.6 or higher, the CogniFit programs will not work. We are sorry for the inconvenience. Our programs need a certain computer power to run properly. For more information about Adobe Flash requirement for Mac, click here.

For PC Users

You will need to have at least Windows Vista to update or install the latest version of Adobe Flash player. To check the system requirements for your PC, click here